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Resale:	nina@zieglersoft.dk

�Ordering

If you are using the DV (demo-version) of "ZieglerCollection one" and find it of use, and want to keep on using it or wants to release your own programs, that uses the collection, you will have to order it.



It is only possible to order "ZieglerCollection one" if paying in advance. Here is how to do it:



"ZieglerCollection one" can be ordered from our web-page at http://www.zieglersoft.dk (It is possible to order it as E-mail version or on diskette). You can order site-licenses and educational licenses from this page too.

"ZieglerCollection one" can be ordered from CompuServe (It is only possible to order it as E-mail version): GO SWREG and use registering number: 14655

Use the "FaxOrder" page from this document. You can order site-licenses and educational licenses using this fax too.

"ZieglerCollection one" can be ordered directly from ZieglerSoft: Send a Eurocheck (or a check drawn on a Danish bank, or an International check) to the following address with your order. Remember, if you want an E-mail version, to include your E-mail address. You can order both the E-mail version and the diskette version directly from ZieglerSoft. The address is:�ZieglerSoft, Rughaven 25.2, DK-9000 Aalborg, Denmark



Prices:

When ordering "ZieglerCollection one", payment has to follow the order. The prices for the 3 versions of "ZieglerCollection one" are as follows:



The trial-version (DV) is free, but can be used only in three weeks, and is without source-code.�This version can be uploaded to BBS's, WWW-sites and such, as long as it is not modified, and no fee is charged for it.

The E-mail version (FV) is $52.00 (American dollars) or DKK 240,00 (Danish kroner) or £31.00 (British pounds). (The DKK price is lower be�ca�u�se when paid in DKK we don't have to pay our bank for the exchange).

The diskette version (FV) is $73.00 (American dollars) or DKK 360,00 (Danish kroner) or £43.00 (British pounds) which includes the cost for mailing it to you. (The DKK price is lower be�cause when paid in DKK we don't have to pay our bank for the exchange).



For site-licenses and educational prices: 

Use the normal ordering service on our homepage at http://www.zieglersoft.dk (Creditcard orders) or please contact:



ZieglerSoft			Phone: +45 9811 3772

Rughaven 25,2		E-mail: sales@zieglersoft.dk

DK-9000 Aalborg, Denmark



If you want to sell ZieglerSoft's software, please contact: 

Nina Ziegler			Phone: +45 9811 3772

ZieglerSoft			E-mail: nina@zieglersoft.dk

Rughaven 25,2

DK-9000 Aalborg, Denmark�Ordering "ZieglerCollection by FAX or MAIL:



If you want to order "ZieglerCollection one" by fax, you have to fill out the next page of this document, and fax it to this fax number:



(+1) 713 524 6398



This number can only be used for ordering, no kind of support is available.



If you want to order by creditcard, and want to use mail, you have to fill out the next page of this document, and mail it to this address:



PSL

P.O.BOX 35705

Houston

TX 77235-5705

USA



This address can only be used for ordering, no kind of support is available.

























































The next page is only for ordering as described above.�FAX or Mail Order for Item #30007

ZieglerCollection one



Ship-To Name & Address: (If a field don't apply, please leave it completely blank)

Please be careful when filling this page, and make sure all information is right. If the addresses are wrong, or the creditcard billing name & address do not match either one of the addresses, the order will not be processed. Get the name and address from the monthly statement.



First/Middle name:	_____________________________	Credit card number:	_________________

Last name:	_____________________________	Expiration month:	____ Year: _______

Company name:	_____________________________	__ MC   __ Visa   __ AMEX   __ Discover

Address line 1:	_____________________________	Bank name and phone-number from card:

Address line 2:	_____________________________	__________________________________

City:	_____________________________

State/Province:	______ -- U.S. & Canada only.

Zip, country:	___________     _______________	Be sure the E-mail address is right

Phone (voice):	_____________________________	E-mail address: _____________________



Credit card Holder's name & address:

Only fill out this if the credit card holder's name or address is different from the ship-to name and address above.



Name on card:	_____________________________

Company name:	_____________________________

Address line 1:	_____________________________

Address line 2:	_____________________________

City:	_____________________________

State/Province:	______ -- U.S. & Canada only.

Zip, country:	___________     _______________



Your Order please:



______	Number of copies at $52 each (Full license)

______	Educational license, number of packs (4 licenses each) at $52 (Not for commercial use)



Site licensees gives you the right to use the product on as many computers at the same time, as the number you enter on the lines below: (Enter the wanted number on the appropriate line)



______	2 to 4 CPU's at $46.80 each

______	5 to 9 CPU's at $44.20 each

______	10 to 24 CPU's at $41.60 each

______	25 to 99 CPU's at $39.00 each

______	100 CPU's and up at £36.40 each



How do you want to receive the product(s)?



______	If you want the product send as E-mail then mark here

______	If you want a diskette with the product, then mark here (Adds $21 for shipping and disk )





Your signature: __________________________________________________________�Software License Agreement

Entire contents copyright ©1996-98 ZieglerSoft, Claus & Nina Ziegler, Rughaven 25, 2, DK-9000 Aalborg, Denmark. All rights reserved. The content of this document or the software itself is subject to change without notice. No part may be reproduced either electronically or mechanically without prior written consent of ZieglerSoft.



Rights and limitations:

This agreement becomes effective when you install all or any part of the software contained on the disk or is part of the zip-file, included with this document. By using our software you agree to the terms of this license. If the terms of this agreement are unacceptable, you may return the package, including this document, diskettes (if any), within 8 days of the purchase date for a refund (E-mail versions can not be returned).



Two versions of the software exists: A demoversion, without source-code, called DV in this document, and a full version, including source-code, called FV in this document (The FV version exist in two versions, one as a ZIP-file sent to you by E-mail from ZieglerSoft, and one sent to you, or bought by you in a store on diskette. There is no difference in the functionality of those two versions, so they are named the same in this document).



The DV version (Demoversion):

ZieglerSoft gives the right to distribute the DV version of this product in an electronic form, as long as there is no direct charge for this distribution. This includes posting the software on WWW-sites, BBS's, CD-ROM or diskette(s). The DV must be distributed in its original form, without any mo�di�fi�ca�tions. The DV version is normally distributed as a ZIP-file (or selfunpacking exe-file) with the name zcd1xxxx.ZIP (or .EXE) (Delphi 1), zcd2xxxx.ZIP (or .EXE) (Delphi 2), zcd3xxxx.ZIP (or .EXE) (Delphi 3) or zcc1xxxx.ZIP (or .EXE) (C++ Builder 1) where xxxx is replaced with the ver�sion�num�ber. You may not include the DV version in any programs you distribute outside your own computer.



You may not use the DV version for writing software for sale, only for your own testing of the units, before buying the FV version. If you want to use the unit in programs outside your own computer, you will have to buy the FV version of the product.



The DV version don't contain sourcecode.



You may use the DV version for testing for three weeks. After three weeks, if you still want to use the unit, then you must buy the FV version of the product.



The FV version (Full version):

ZieglerSoft provides the software and grants non-exclusive use of its contents. The software which accompanies this license ("ZieglerCollection one") is the property of ZieglerSoft and is protected by copyright law. By using "ZieglerCollection one" (the FV version) you agree to abide by the terms of this agreement. Only one user may use this software on a single computer. This software may not be used on a network or any other multi-user platform. Contact ZieglerSoft if you need a SITE or network license. You may make backup copies for your own use only. When "ZieglerCollection one" is being compiled into an executable with the extensions ".exe" or ".dll" then there are no licensing fees or royalties for distribution of the executable file. Should any part of ZieglerCollection one be used in a noncompiled application, such as: a value added VCL, VBX, OCX or anything like that, royalties do apply. �Failure to comply with the terms outlined in this agreement will result in termination of your software license.



You may not:

Use the product or make copies except as provided by this license.

Translate, reverse engineer, decompile or disassemble this software (the FV version is provided in source-code), except to the extent this restriction is prohibited by applicable regulations.

Use this software package in a manner that violates any law in the jurisdiction of its use or selling market.

Rent, lease, assign or transfer this program.



Limited Warranty:

THE ZIEGLERCOLLECTION ONE SOFTWARE CONTAINED IN THIS PACKAGE IS PROVIDED "AS IS" WHIT�OUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED. THIS IN�CLUDE, BUT NOT LIMITED TO MERCHANTIBILITY AND FITNESS FOR A PARTI�CULAR FUNC�TION. THE INTIRE RISK RELATED TO PRODUCT PERFORMANCE OR QUALITY IS AS�SU�MED BY THE USER. IN THE UNLIKELY EVENT A DEFECT IS DIS�COVERED, YOU AS�SU�ME THE ENTIRE COST OF ANY REMEDIAL ACTION. ZIEGLERSOFT'S ENTIRE LI�ABI�LI�TY IS LIMITED TO THE ORIGINAL PURCHASE PRICE OF ZIEGLERCOLLECTION ONE. SOME JURIS�DIC�TI�ONS DO NOT ALLOW EXCLUSIONS OF IMPLIED WARRANTIES, THUS THE ABOVE EX�CLU�SIONS MAY NOT APPLY TO YOU. 

	

ZieglerSoft does not warrant the software contained in this package will meet your requirements or the software will function in an uninterrupted and errorfree manor. Should the diskette(s) (if any) be damaged or rendered unusable under normal use, ZieglerSoft will replace them within the first 90 days at no additional charge. Evidence of purchase (original sales receipt) is required for replace�ment.



Important notice:

"ZieglerCollection one" is copyrighted by ZieglerSoft. "ZieglerCollection one" is a trademark of ZieglerSoft. DOS, Windows, Delphi, Borland and Turbo Pascal are trademarks or registered trademarks of their respective holders. 



�Included in the package should be the following:

The "ZieglerCollection one" is distributed in a single file, that can be a ZIP-file or a selfunpacking EXE-file. Depending on what version you have, you should have the following file:



Demoversion for Delphi 1: ZCD1xxxx.ZIP or ZCD1xxxx.EXE

Demoversion for Delphi 2: ZCD2xxxx.ZIP or ZCD2xxxx.EXE

Demoversion for Delphi 3: ZCD3xxxx.ZIP or ZCD3xxxx.EXE

Demoversion for Borland C++ Builder 1: ZCC1xxxx.ZIP or ZCC1xxxx.EXE

Demoversion for Borland C++ Builder 3: ZCC3xxxx.ZIP or ZCC3xxxx.EXE

Full version with source-code: ZCFxxxx.EXE



In the file-names above, xxxx will be replaced with the versionnumber of the "ZieglerCollection one" package. An example could be (for version 1.20): ZCD10120.EXE for a Delphi 1 demoversion.



When these files are unpacked (preserving the directory-structure) or run, they will create several new directories, in which all files needed for installation of the product into Delphi or C++ Builder are. If you down-loaded one of the demoversions somewhere, you can see how to unpack the file on our homepage at http://www.zieglersoft.dk. If you got a full version, you would, if received on diskette, have a README.TXT file that tells how to unpack, or else you will have an E-mail from ZieglerSoft, that tell how to do the unpacking.





How to install:

When the distribution-file is unpacked, the following should be followed to install the various versions of "ZieglerCollection one":



Before installation:

Be sure that you have closed all projects in Delphi/C++

Be sure you have uninstalled all earlier versions of "ZieglerCollection one"�(you must follow the un-installation procedure if you are upgrading from a version before 1.21)�See the un-installation procedure later in this document. If you are upgrading, you need to read the part about upgrading too, because some stuff have changed since version 1.20, to make the product compatible with other products, like RxLIB (A free component-library from Russia).

Close Delphi/C++



Demoversion for Delphi 1:

Copy all files from the directory "Delphi1" to the directory where you want to install the demoversion.

Copy all files from the directory "DDemo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

To be sure, make a copy of the file "Complib.dcl" in your "\bin\" directory to a secure place, just in case something goes wrong when installing the components.

Start Delphi

In the menu "Options" select "Install components..."

Choose "Add" then "Browse"

Find the directory from 1.

Select the file "ZS_VCL.DCU"

You should now have the components of "ZieglerCollection one" 



Demoversion for Delphi 2:

Copy all files from the directory "Delphi2" to the directory where you want to install the demoversion.

Copy all files from the directory "DDemo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

To be sure, make a copy of the file "Cmplib32.dcl" in your "\bin\" directory to a secure place, just in case something goes wrong when installing the components.

Start Delphi

In the menu "Component" select "Install..."

Choose "Add" then "Browse"

Find the directory from 1.

Select the file "ZS_VCL32.DCU"

When the component-library is compiled, close Delphi down, and start it up again

In the menu "Component" select "ZieglerSoft Library-Path-Extender"

Be sure the directory from 1. is in the list, and if not, choose "Add" and key it in.

Close Delphi again, and when started again, it is ready for use.

You should now have the components of "ZieglerCollection one" 



Demoversion for Delphi 3:

Copy all files from the directory "Delphi3" to the directory where you want to install the demoversion.

Copy all files from the directory "DDemo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

Start Delphi

In the menu "Component" select "Install Packages" then choose "Add"

Locate the directory from 1., and select the file "ZC.dpl"

When the component-library is compiled, close Delphi down, and start it up again

In the menu "Component" select "ZieglerSoft Library-Path-Extender"

Be sure the directory from 1. is in the list, and if not, choose "Add" and key it in.

Close Delphi again, and when started again, it is ready for use.

You should now have the components of "ZieglerCollection one" 



Demoversion for C++ Builder 1:

Copy all files from the directory "Cpp1" to the directory where you want to install the demoversion.

Copy all files from the directory "CDemo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

To be sure, make a copy of the file "Cmplib32.ccl" in your "\bin\" directory to a secure place, just in case something goes wrong when installing the components.

Start C-Builder

In the menu "Options" select "Environment" then "Library" and in the field "Include Path", add a ";" (with out " and ") and the path from 1.

Close down C++ Builder, and start it again.

In the menu "Component" select "Install..."

Choose "Add" then "Browse"

Find the directory from 1.

Select the file "ZS_VCL32.OBJ"

When the component-library is compiled, close C++ Builder down, and start it up again

In the menu "Component" select "ZieglerSoft Library-Path-Extender"

Be sure the directory from 1. is in the list, and if not, choose "Add" and key it in.

Close C++ Builder again, and when started again, it is ready for use.

You should now have the components of "ZieglerCollection one" 



If you have troubles compiling the library with the new components, try to disable the "Use Incremental linker" on the "Options" -> "Environment" -> "Library" menu.



Demoversion for C++ Builder 3:

Copy all files from the directory "Cpp3" to the directory where you want to install the demoversion.

Copy all files from the directory "CPP3Demo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

Start C-Builder

In the menu "Components" select "Install packages", select "Add" and search for the path from step 1 above, select the file "zc.bpl"

Close down C++ Builder, and start it again.

In the menu "Component" select "ZieglerSoft Library-Path-Extender"

Be sure the directory from 1. is in the list, and if not, choose "Add" and key it in.

Close C++ Builder again, and when started again, it is ready for use.

You should now have the components of "ZieglerCollection one" 



If you have troubles compiling the library with the new components, try to enable the "Don't generate statefile" on the "Project"->"Options" -> "Linker" menu.



Full version, installed on Delphi 1:

(Remember, if you have the full version, and want to install in more than one Delphi/C++ Builder version, you have to install into different directories for every version. You can't share an install-directory between different versions of Delphi/C++ Builder)

Copy all files from the directory "Delphi1" to the directory where you want to install it

Copy all files from the directory "Common" the SAME directory as in 1.

Copy all files from the directory "DDemo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

To be sure, make a copy of the file "Complib.dcl" in your "\bin\" directory to a secure place, just in case something goes wrong when installing the components.

Start Delphi

In the menu "Options" select "Install components..."

Choose "Add" then "Browse"

Find the directory from 1.

Select the file "ZS_VCL.PAS"

You should now have the components of "ZieglerCollection one" 



Full version, installed on Delphi 2:

(Remember, if you have the full version, and want to install in more than one Delphi/C++ Builder version, you have to install into different directories for every version. You can't share an install-directory between different versions of Delphi/C++ Builder)

Copy all files from the directory "Delphi2" to the directory where you want to install it.

Copy all files from the directory "Common" to the same directory as in 1.

Copy all files from the directory "DDemo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

To be sure, make a copy of the file "Cmplib32.dcl" in your "\bin\" directory to a secure place, just in case something goes wrong when installing the components.

Start Delphi

In the menu "Component" select "Install..."

Choose "Add" then "Browse"

Find the directory from 1.

Select the file "ZS_VCL32.PAS"

When the component-library is compiled, close Delphi down, and start it up again

In the menu "Component" select "ZieglerSoft Library-Path-Extender"

Be sure the directory from 1. is in the list, and if not, choose "Add" and key it in.

Close Delphi again, and when started again, it is ready for use.

You should now have the components of "ZieglerCollection one" 



Full version, installed on Delphi 3:

(Remember, if you have the full version, and want to install in more than one Delphi/C++ Builder version, you have to install into different directories for every version. You can't share an install-directory between different versions of Delphi/C++ Builder)

Copy all files from the directory "Delphi3" to the directory where you want to install it.

Copy all files from the directory "Common" to the same directory as in 1.

Copy all files from the directory "DDemo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

Start Delphi

In the "File"->"Open" menu, browse to find the file "ZC.DPK", which can be found in the directory from step 1.

Select "Compile", and when done, close the window.

In the menu "Component" select "Install Packages" then choose "Add"

Locate the directory from 1., and select the file "ZC.dpl"

When the component-library is compiled, close Delphi down, and start it up again

In the menu "Component" select "ZieglerSoft Library-Path-Extender"

Be sure the directory from 1. is in the list, and if not, choose "Add" and key it in.

Close Delphi again, and when started again, it is ready for use.

You should now have the components of "ZieglerCollection one" 



Full version, installed on C++ Builder 1:

(Remember, if you have the full version, and want to install in more than one Delphi/C++ Builder version, you have to install into different directories for every version. You can't share an install-directory between different versions of Delphi/C++ Builder)

Copy all files from the directory "Cpp1" to the directory where you want to install it.

Copy all files from "Common" to the same directory as in 1.

Copy all files from the directory "CDemo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

To be sure, make a copy of the file "Cmplib32.ccl" in your "\bin\" directory to a secure place, just in case something goes wrong when installing the components.

Start C-Builder

In the menu "Component" select "Install..."

Choose "Add" then "Browse"

Find the directory from 1.

Select the file "ZS_VCL32.PAS"

When the component-library is compiled, close C++ Builder down, and start it up again

In the menu "Component" select "ZieglerSoft Library-Path-Extender"

Be sure the directory from 1. is in the list, and if not, choose "Add" and key it in.

Close C++ Builder again, and when started again, it is ready for use.

You should now have the components of "ZieglerCollection one" 



If you have troubles compiling the library with the new components, try to disable the "Use Incremental linker" on the "Options" -> "Environment" -> "Library" menu.





Full version, installed on C++ Builder 3:

(Remember, if you have the full version, and want to install in more than one Delphi/C++ Builder version, you have to install into different directories for every version. You can't share an install-directory between different versions of Delphi/C++ Builder)

Copy all files from the directory "Cpp3" to the directory where you want to install it.

Copy all files from "Common" to the same directory as in 1.

Copy all files from the directory "CPP3Demo" to a directory where you want the demo-files (the files show you how to use many of the components in the collection).

Copy all files from the directory "Help" to a directory, that is part of the "path" on your machine, so that Windows-help system can find it.

Start C-Builder

In the "File" -> "Open project" browse for the file "zc.bpk" in the directory from step 1. Open it.

Select "Project" -> "Build"

In the menu "Component" select "Install packages", then "Add". Browse to find the directory from step 1, select the file "zc.bpl"

Close C++ Builder down, and start it up again

In the menu "Component" select "ZieglerSoft Library-Path-Extender"

Be sure the directory from 1. is in the list, and if not, choose "Add" and key it in.

Close C++ Builder again, and when started again, it is ready for use.

You should now have the components of "ZieglerCollection one" 



If you have troubles compiling the library with the new components, try to enable the "Don't generate statefile" on the "Project"->"Options" -> "Linker" menu.





What now?:

Now you are ready to use the "ZieglerCollection one". If you want help with components, have a look in the demofiles, and try to drop a component on a form, right-click it, and select "Help for component".



The C++ Builder 1 demo-projects need a little change before you can run them. Load the wanted demo-project into C++ Builder, go into the menu: "Options" > "Project" > "Directories" and change the "Include path". You have to delete the path: "CHANGE_THIS" and put the right one in. The right one, is the directory where the files from "ZieglerCollection one" is. Next you have to change the "Library path" in the same way. Now you can compile the project.



The C++ Builder 3 demo-projects need a little change before you can run them. Load the wanted demo-project into C++ Builder, go into the menu: "Projects">Options" >"Directories/Conditionals" and change the "Include path". You have to delete the path: "CHANGE_THIS" and put the right one in. The right one, is the directory where the files from "ZieglerCollection one" is. Next you have to change the "Library path" in the same way. Now you can compile the project.



Help for the collection can be found in the "Help" menu too. Remember to look by our homepage, to see if a new version of the help-file should be ready, because this file is updated regularly, even when the collection itself is not.



A little tip: The "ZieglerSoft Library-Path-Extender" found in all 32-bit version of "ZieglerCollection one", can be used to make a search-path that is longer than the standard Delphi normally will do. The changes you make in this tool, will be in effect the next time you start Delphi/C++ Builder.



Questions? Ask them to this E-mail address: zieglercollection@zieglersoft.dk, or take a look at our homepage at http://www.zieglersoft.dk to see if the question already is answered.�How to un-install:



Delphi 1:

Close all projects

In the menu "Options", select "Install components"

Select ZS_VCL in the list

Click "Remove", then "OK"

When the library is compiled, right-click on the tool-palette, select "Configure.."

Delete "ZieglerSoft", "ZieglerSoft II" (if it exist) and "ZieglerSoft III" (if it exist)

Select "OK" and close Delphi down.

If you want to remove "ZieglerCollection one" completely from your PC, you can now delete all the files that were originally copied to it. If you are upgrading to a newer version of "ZieglerCollection one", you only need to delete all files starting with "animate.*". This is because this file has changed name in versions after 1.20 to zAnimate.* (Read about this on the Upgrade page)



Delphi 2:

Close all projects

In the menu "Component", select "Install "

Select ZS_VCL32 in the list

Click "Remove", then "OK"

When the library is compiled, right-click on the tool-palette, select "Properties"

Delete "ZieglerSoft", "ZieglerSoft II" (if it exist) and "ZieglerSoft III" (if it exist)

Select "OK" and close Delphi down.

If you want to remove "ZieglerCollection one" completely from your PC, you can now delete all the files that were originally copied to it. If you are upgrading to a newer version of "ZieglerCollection one", you only need to delete all files starting with "animate.*". This is because this file has changed name in versions after 1.20 to zAnimate.* (Read about this on the Upgrade page)



Delphi 3:

Close all projects

In the menu "Component", select "Install packages"

Select ZS_VCL32 in the list

Remove "ZieglerCollection one", answer "Yes" to delete it, select "OK"

Right-click on the tool-palette, select "Properties"

Delete "ZieglerSoft", "ZieglerSoft II" and "ZieglerSoft III"

Select "OK" and close Delphi down.

If you are upgrading to a new version of "ZieglerCollection" you have a small program in the Delphi3 directory made when unpacking the new version, called "REMOVED3.EXE". Run this to finally remove the old tool-bars. (You have to do this, or the new version will be on wrong tool-bars when installed)

If you want to remove "ZieglerCollection one" completely from your PC, you can now delete all the files that were originally copied to it. If you are upgrading to a newer version of "ZieglerCollection one", you only need to delete all files starting with "animate.*" and all files starting with "ZieglerCollection.*". This is because the files has changed name in versions after 1.20.







C++ Builder 1:

Close all projects

In the menu "Component", select "Install "

Select ZS_VCL32 in the list

Click "Remove", then "OK"

When the library is compiled, right-click on the tool-palette, select "Properties"

Delete "ZieglerSoft", "ZieglerSoft II" (if it exist) and "ZieglerSoft III" (if it exist)

Select "OK" and close C++ Builder down.

If you want to remove "ZieglerCollection one" completely from your PC, you can now delete all the files that were originally copied to it. If you are upgrading to a newer version of "ZieglerCollection one", you only need to delete all files starting with "animate.*". This is because this file has changed name in versions after 1.20 to zAnimate.* (Read about this on the Upgrade page)



C++ Builder 3:

Close all projects

In the menu "Component", select "Install packages"

Select "ZieglerCollection one" in the list

Click "Remove", then "OK" 

Right-click on the tool-palette, select "Properties"

Delete "ZieglerSoft", "ZieglerSoft II" and "ZieglerSoft III"

Select "OK" and close C++ Builder down.

If you want to remove "ZieglerCollection one" completely from your PC, you can now delete all the files that were originally copied to it. If you are upgrading to a newer version of "ZieglerCollection one", you only need to delete all files starting with "animate.*". This is because this file has changed name in versions after 1.20 to zAnimate.* (Read about this on the Upgrade page)





Upgrading to versions from 1.21 and up:



Before you can upgrade, you need to un-install "ZieglerCollection one" as described in "How to un-install".



If you want to put the new files in the directory where you had the old version, you will need to delete all files starting with "ANIMATE.*" and "ZIEGLERCOLLECTION.*" because the names of these files is changed from version 1.21 and up.



The reason for the change in names is that some people had problems when trying to have "ZieglerCollection" installed together with other components, such as RxLIB.



ANIMATE.* is changed to ZANIMATE.* from version 1.21 and up

ZIEGLERCOLLECTION.* is changed to ZC.* from version 1.30 and up



This means that programs compiled with the older versions of "ZieglerCollection one" are still looking for files with the name "animate". You will have to manually change all such references to "zanimate". We are sorry about that, but we think that our product should be as compatible with other products as possible.



If you earlier have used a component from us, called "TzCompCanvas" then this one needs to be un-installed too, because a new version of that component is now part of "ZieglerCollection". Remember to remove the directory, where that component was installed, from the search-path, or to delete the file where the component lives, because the name of the file it was included in, is now used by "ZieglerCollection"



When you have un-installed as described, you can continue with an installation as described in "How to install"








